버그 해결을 위한 모든 질문을 던져
0 votes
224 views
import kotlinx.coroutines.launch
import kotlinx.coroutines.runBlocking

요거 사용해서 코틀린 launch와 runBlocking 사용하려고 하는데 라이브러리가 인식이 안됩니다.

정확히는 kotlinx 여기서 빨간색 뜹니다.

 

아무리 찾아봐도 답이 안보이네요.

별도의 파일을 임포트해야 하는건지 아니면 자바 버전을 조절해야 하는건지 알 수가 없네요.

안드로이드 관련은 아니고 순수 코틀린으로만 작업하고 있고, 인텔리J IDEA에서 작업중입니다.

asked (54 point) , 224 views

1 답변

0 votes

아무리 찾아봐도 답이 안 보인다면 아래 멤버들에게 연락해보면 어떨까요?

https://www.meetup.com/ko-KR/kotlinkr/members/

answered (19 point)

제가 올린 질문 : https://stackoverflow.com/questions/56357566/import-kotlinx-is-impossible-in-intellij-idea

결론 :  kotlin - JVM | IDEA. 포기하고 Gradle - Kotlin/JVM으로 새로 프로젝트 만드니까 라이브러리 임포트 가능은 하더라구요. 그래들 말고 코틀린 라이브러리로 어케 넣는지는 모르겠는데 일단 되긴 됩니다

버그 해결을 위해 도움을 구하고, 도움을 주세요. 우리는 그렇게 발전합니다.

throw bug 는 프로그래밍에 대한 전분야를 다룹니다. 질문,논의거리,팁,정보공유 모든 것이 가능합니다. 프로그래밍과 관련이 없는 내용은 환영받지 못합니다.

253 질문
387 answers
394 댓글
507 users