버그 해결을 위한 모든 질문을 던져
0 votes
125 views
이번에 support 라이브러리를 28버전으로 올리면서 발생하는 에러인데

 

기존에는 26버전을 사용했거든요 support-compat.aar 26버전에는 v4/util/ArrayMap.Class 이 존재하는데

support-compat.aar 28버전에는 존재하지 않더라구요. 그래서 발생하는 에러같은데

이걸 해결하는 법이 있을까요... 해당 클래스가 다른 라이브러리로 옮겨진건지 .. 어떻게 된건지 모르겠네요

ArrayMap을 Firebase 라이브러리에서 사용해서 앱실행하자마자 위의 에러 발생과 함께 크래쉬 나는중인데 1주넘게 이걸로

헤딩중이라 너무 답답한 맘에 글올려봅니다.
폐쇄 기록: 해결방법 찾음
asked (6 point)
closed , 125 views

1 답변

0 votes
자답 - 28버전 올라오면서 라이브러리가 더 분화 되었네요

Collections.jar 추가하니까 잘됩니다
answered (6 point)

버그 해결을 위해 도움을 구하고, 도움을 주세요. 우리는 그렇게 발전합니다.

throw bug 는 프로그래밍에 대한 전분야를 다룹니다. 질문,논의거리,팁,정보공유 모든 것이 가능합니다. 프로그래밍과 관련이 없는 내용은 환영받지 못합니다.

151 질문
253 answers
276 댓글
263 users